package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b((\d|[a-zA-Z]{1,2})\d{7})\b`)
var str = `X1234567
PA1234567
12345678
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}