const regex = /\b((\d|[a-zA-Z]{1,2})\d{7})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((\\d|[a-zA-Z]{1,2})\\d{7})\\b', 'gm')
const str = `X1234567
PA1234567
12345678
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}