import Foundation
let pattern = #"^(我说(了)?|(我)?跟你说|(我)?说的是)?请?你?(.{0,2}我)?(把)?(音乐|歌曲|音响|音箱|播放)?(暂停|停)(下|一下|一会|一会儿)?(音乐|播放|音响|音箱|歌曲|音乐播放器)?(了)?(听到(了)?(吗|没|没有)|(你)?还放)?.{0,1}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
我不听了
你别放了
我不想听了
别放了
我要听音乐
我不要听
我不听
别放了啊
跟你说别放了
你别放了听到没
你别放了还放
别放了你
你结束
你别放了啊
快把音乐关上
关闭音响
关闭音乐
关掉音乐
关掉播放器
你关掉音乐
你给我关掉音乐
暂停音乐
把音乐停下来
你把音乐停下来
暂停播放
暂停音乐播放器
给我停下
停下来
音乐停下来
暂停
你给我停下
快给我停下
停
暂停一下呗
停下
唱的真难听
好难听
真难听啊
不好听
不喜欢
真的不喜欢
不喜欢这首歌
不喜欢这个
你唱的太难听了
好难听
不想听音乐
别放音乐
不听音乐
想听周杰伦的歌
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)