#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(我说(了)?|(我)?跟你说|(我)?说的是)?请?你?(.{0,2}我)?(把)?(音乐|歌曲|音响|音箱|播放)?(暂停|停)(下|一下|一会|一会儿)?(音乐|播放|音响|音箱|歌曲|音乐播放器)?(了)?(听到(了)?(吗|没|没有)|(你)?还放)?.{0,1}$"
Local $sString = "我不听了" & @CRLF & _
"你别放了" & @CRLF & _
"我不想听了" & @CRLF & _
"别放了" & @CRLF & _
"我要听音乐" & @CRLF & _
"我不要听" & @CRLF & _
"我不听" & @CRLF & _
"别放了啊" & @CRLF & _
"跟你说别放了" & @CRLF & _
"你别放了听到没" & @CRLF & _
"你别放了还放" & @CRLF & _
"别放了你" & @CRLF & _
"你结束" & @CRLF & _
"你别放了啊" & @CRLF & _
"快把音乐关上" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"关闭音响" & @CRLF & _
"关闭音乐" & @CRLF & _
"关掉音乐" & @CRLF & _
"关掉播放器" & @CRLF & _
"你关掉音乐" & @CRLF & _
"你给我关掉音乐" & @CRLF & _
"" & @CRLF & _
"暂停音乐" & @CRLF & _
"把音乐停下来" & @CRLF & _
"你把音乐停下来" & @CRLF & _
"暂停播放" & @CRLF & _
"暂停音乐播放器" & @CRLF & _
"给我停下" & @CRLF & _
"停下来" & @CRLF & _
"音乐停下来" & @CRLF & _
"暂停" & @CRLF & _
"你给我停下" & @CRLF & _
"快给我停下" & @CRLF & _
"停" & @CRLF & _
"暂停一下呗" & @CRLF & _
"停下" & @CRLF & _
"" & @CRLF & _
"唱的真难听" & @CRLF & _
"好难听" & @CRLF & _
"真难听啊" & @CRLF & _
"不好听" & @CRLF & _
"不喜欢" & @CRLF & _
"真的不喜欢" & @CRLF & _
"不喜欢这首歌" & @CRLF & _
"不喜欢这个" & @CRLF & _
"你唱的太难听了" & @CRLF & _
"好难听" & @CRLF & _
"" & @CRLF & _
"不想听音乐" & @CRLF & _
"别放音乐" & @CRLF & _
"不听音乐" & @CRLF & _
"想听周杰伦的歌" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")