import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(我说(了)?|(我)?跟你说|(我)?说的是)?请?你?(.{0,2}我)?(把)?(音乐|歌曲|音响|音箱|播放)?(暂停|停)(下|一下|一会|一会儿)?(音乐|播放|音响|音箱|歌曲|音乐播放器)?(了)?(听到(了)?(吗|没|没有)|(你)?还放)?.{0,1}$";
final String string = "我不听了\n"
+ "你别放了\n"
+ "我不想听了\n"
+ "别放了\n"
+ "我要听音乐\n"
+ "我不要听\n"
+ "我不听\n"
+ "别放了啊\n"
+ "跟你说别放了\n"
+ "你别放了听到没\n"
+ "你别放了还放\n"
+ "别放了你\n"
+ "你结束\n"
+ "你别放了啊\n"
+ "快把音乐关上\n\n\n"
+ "关闭音响\n"
+ "关闭音乐\n"
+ "关掉音乐\n"
+ "关掉播放器\n"
+ "你关掉音乐\n"
+ "你给我关掉音乐\n\n"
+ "暂停音乐\n"
+ "把音乐停下来\n"
+ "你把音乐停下来\n"
+ "暂停播放\n"
+ "暂停音乐播放器\n"
+ "给我停下\n"
+ "停下来\n"
+ "音乐停下来\n"
+ "暂停\n"
+ "你给我停下\n"
+ "快给我停下\n"
+ "停\n"
+ "暂停一下呗\n"
+ "停下\n\n"
+ "唱的真难听\n"
+ "好难听\n"
+ "真难听啊\n"
+ "不好听\n"
+ "不喜欢\n"
+ "真的不喜欢\n"
+ "不喜欢这首歌\n"
+ "不喜欢这个\n"
+ "你唱的太难听了\n"
+ "好难听\n\n"
+ "不想听音乐\n"
+ "别放音乐\n"
+ "不听音乐\n"
+ "想听周杰伦的歌\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}