$re = '/^(?i)(?!foo$).+/m';
$str = 'Text with foo here
foo Text
More foo
foo
Match this line
this seems to work
as does this with foo
foofff
ffffoO
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);