import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?i)(?!foo$).+";
final String string = "Text with foo here\n"
+ "foo Text\n"
+ "More foo\n"
+ "foo\n\n"
+ "Match this line\n\n"
+ "this seems to work\n"
+ "as does this with foo \n"
+ "foofff\n"
+ "ffffoO\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}