using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?i)(?!foo$).+";
string input = @"Text with foo here
foo Text
More foo
foo
Match this line
this seems to work
as does this with foo
foofff
ffffoO
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}