use strict;
my $str = 'abc';
my $regex = qr/^[a-zA-Z0-9\s_]+$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";