const regex = /^[a-zA-Z0-9\s_]+$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9\\s_]+$', 'g')
const str = `abc`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);