re = /[0-9]{8}_[0-9]{1,6}/m
str = '20101112_131415
20101112_1314
20101112_13
20101112_1
20202212_99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end