package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{8}_[0-9]{1,6}`)
var str = `20101112_131415
20101112_1314
20101112_13
20101112_1
20202212_99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}