$re = '/[0-9]{8}_[0-9]{1,6}/m';
$str = '20101112_131415
20101112_1314
20101112_13
20101112_1
20202212_99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);