package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\'\S*\')?(<|>|>=|<=|=|<>)'(\S| )*'$`)
var str = `'alpha_trial'='ali mahir'
='cocktail kebab'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}