$re = '/^.{0,2}(给我|能不能|帮我|请)?(简单)?(介绍|讲讲|说说)(一下|介绍)?#(的情况)?(好不好|可以吗|可以么|吧|阿|啊|呢|哦|哟|呀|呗)?$/m';
$str = '介绍一下#
给我说说#
给我介绍一下#吧
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);