import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.{0,2}(给我|能不能|帮我|请)?(简单)?(介绍|讲讲|说说)(一下|介绍)?#(的情况)?(好不好|可以吗|可以么|吧|阿|啊|呢|哦|哟|呀|呗)?$";
final String string = "介绍一下#\n"
+ "给我说说#\n"
+ "给我介绍一下#吧\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}