use strict;
my $str = '介绍一下#
给我说说#
给我介绍一下#吧
';
my $regex = qr/^.{0,2}(给我|能不能|帮我|请)?(简单)?(介绍|讲讲|说说)(一下|介绍)?#(的情况)?(好不好|可以吗|可以么|吧|阿|啊|呢|哦|哟|呀|呗)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}