// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(sierra-cp|sierracp|sierra-cpengineering|sierracpengineering|sierracpeng|sierraemissions)(\.net|\.com|\.org|\.us|\.cn)\/?(([a-zA-Z0-9_\-\.]+\/?){0,})").unwrap();
let string = "sierra-cp.com/cat/eat";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}