package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(sierra-cp|sierracp|sierra-cpengineering|sierracpengineering|sierracpeng|sierraemissions)(\.net|\.com|\.org|\.us|\.cn)\/?(([a-zA-Z0-9_\-\.]+\/?){0,})`)
var str = `sierra-cp.com/cat/eat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}