re = /(sierra-cp|sierracp|sierra-cpengineering|sierracpengineering|sierracpeng|sierraemissions)(\.net|\.com|\.org|\.us|\.cn)\/?(([a-zA-Z0-9_\-\.]+\/?){0,})/
str = 'sierra-cp.com/cat/eat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end