$re = '/\s*(?!#)(?:.*run\s)?(\bride\b).*?(\bmount\b|\bdismount\b)/i';
$str = 'ride <target> mount <vehicle>
Makes <target> ride on <vehicle>.
ride <target> dismount';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);