#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\s*(?!#)(?:.*run\s)?(\bride\b).*?(\bmount\b|\bdismount\b)"
Local $sString = "ride <target> mount <vehicle>" & @CRLF & _
"Makes <target> ride on <vehicle>." & @CRLF & _
"ride <target> dismount"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")