const regex = /\s*(?!#)(?:.*run\s)?(\bride\b).*?(\bmount\b|\bdismount\b)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?!#)(?:.*run\\s)?(\\bride\\b).*?(\\bmount\\b|\\bdismount\\b)', 'gi')
const str = `ride <target> mount <vehicle>
Makes <target> ride on <vehicle>.
ride <target> dismount`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}