// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(^[A-Z]{2}[:] ?)?\d+\|(([A-Z]{2}, ?)*)[A-Z]{2} \"\w+\"?"#).unwrap();
let string = "LE: 20|XX, XY, XZ \"ciao\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}