using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[A-Z]{2}[:] ?)?\d+\|(([A-Z]{2}, ?)*)[A-Z]{2} \""\w+\""?";
string input = @"LE: 20|XX, XY, XZ ""ciao""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}