import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[A-Z]{2}[:] ?)?\\d+\\|(([A-Z]{2}, ?)*)[A-Z]{2} \\\"\\w+\\\"?";
final String string = "LE: 20|XX, XY, XZ \"ciao\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}