use strict;
my $str = 'dns.e5.sk
salt.e5.sk
rsys.e5.sk
arb.e5.sk
asplog.e5.sk
mri.e5.sk
ipt.e5.sk
sample.e5.sk
stat.e5.sk
setting.e5.sk
gid.e5.sk';
my $regex = qr/^(?:dns|salt|rsys|arb|asplog|mri|ipt|sample|stat|setting|gid)\.e5\.sk$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}