import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:dns|salt|rsys|arb|asplog|mri|ipt|sample|stat|setting|gid)\\.e5\\.sk$";
final String string = "dns.e5.sk\n"
+ "salt.e5.sk\n"
+ "rsys.e5.sk\n"
+ "arb.e5.sk\n"
+ "asplog.e5.sk\n"
+ "mri.e5.sk\n"
+ "ipt.e5.sk\n"
+ "sample.e5.sk\n"
+ "stat.e5.sk\n"
+ "setting.e5.sk\n"
+ "gid.e5.sk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}