#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:dns|salt|rsys|arb|asplog|mri|ipt|sample|stat|setting|gid)\.e5\.sk$"
Local $sString = "dns.e5.sk" & @CRLF & _
"salt.e5.sk" & @CRLF & _
"rsys.e5.sk" & @CRLF & _
"arb.e5.sk" & @CRLF & _
"asplog.e5.sk" & @CRLF & _
"mri.e5.sk" & @CRLF & _
"ipt.e5.sk" & @CRLF & _
"sample.e5.sk" & @CRLF & _
"stat.e5.sk" & @CRLF & _
"setting.e5.sk" & @CRLF & _
"gid.e5.sk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")