import Foundation
let pattern = #"(.*)(Afronding)([0-9\"\.\s:]*)(,\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"ImsManifestIdentifier": "MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58",
"PackageGuid": "ab8b5d84-b165-4806-a5fc-58d00ce2a195",
"PackageVersie": 223296366,
"ToetsGuid": "09f5836d-285a-4970-ad93-fb9610201e15",
"ToetsVersie": 10001,
"RuweScore": "0",
"Vaardigheid": "0",
"Afronding": "1",
"SchoolTypes": {
"VOVMBO": "1",
"MBO2": "1",
"MBO3": "1"
}
}, {
"ImsManifestIdentifier": "MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58",
"PackageGuid": "ab8b5d84-b165-4806-a5fc-58d00ce2a195",
"PackageVersie": 223296366,
"ToetsGuid": "09f5836d-285a-4970-ad93-fb9610201e15",
"ToetsVersie": 10001,
"RuweScore": "1",
"Vaardigheid": "14,0",
"Afronding": "1",
"SchoolTypes": {
"VOVMBO": "1,1",
"MBO2": "1,1",
"MBO3": "1"
}
}, {
"ImsManifestIdentifier": "MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58",
"PackageGuid": "ab8b5d84-b165-4806-a5fc-58d00ce2a195",
"PackageVersie": 223296366,
"ToetsGuid": "09f5836d-285a-4970-ad93-fb9610201e15",
"ToetsVersie": 10001,
"RuweScore": "2",
"Vaardigheid": "23",
"Afronding": "1",
"SchoolTypes": {
"VOVMBO": "2,5",
"MBO2": "2,5",
"MBO3": "1,5"
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)