import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(Afronding)([0-9\\\"\\.\\s:]*)(,\\n)";
final String string = "{\n"
+ " \"ImsManifestIdentifier\": \"MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58\",\n"
+ " \"PackageGuid\": \"ab8b5d84-b165-4806-a5fc-58d00ce2a195\",\n"
+ " \"PackageVersie\": 223296366,\n"
+ " \"ToetsGuid\": \"09f5836d-285a-4970-ad93-fb9610201e15\",\n"
+ " \"ToetsVersie\": 10001,\n"
+ " \"RuweScore\": \"0\",\n"
+ " \"Vaardigheid\": \"0\",\n"
+ " \"Afronding\": \"1\",\n"
+ " \"SchoolTypes\": {\n"
+ " \"VOVMBO\": \"1\",\n"
+ " \"MBO2\": \"1\",\n"
+ " \"MBO3\": \"1\"\n"
+ " }\n"
+ " }, {\n"
+ " \"ImsManifestIdentifier\": \"MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58\",\n"
+ " \"PackageGuid\": \"ab8b5d84-b165-4806-a5fc-58d00ce2a195\",\n"
+ " \"PackageVersie\": 223296366,\n"
+ " \"ToetsGuid\": \"09f5836d-285a-4970-ad93-fb9610201e15\",\n"
+ " \"ToetsVersie\": 10001,\n"
+ " \"RuweScore\": \"1\",\n"
+ " \"Vaardigheid\": \"14,0\",\n"
+ " \"Afronding\": \"1\",\n"
+ " \"SchoolTypes\": {\n"
+ " \"VOVMBO\": \"1,1\",\n"
+ " \"MBO2\": \"1,1\",\n"
+ " \"MBO3\": \"1\"\n"
+ " }\n"
+ " }, {\n"
+ " \"ImsManifestIdentifier\": \"MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58\",\n"
+ " \"PackageGuid\": \"ab8b5d84-b165-4806-a5fc-58d00ce2a195\",\n"
+ " \"PackageVersie\": 223296366,\n"
+ " \"ToetsGuid\": \"09f5836d-285a-4970-ad93-fb9610201e15\",\n"
+ " \"ToetsVersie\": 10001,\n"
+ " \"RuweScore\": \"2\",\n"
+ " \"Vaardigheid\": \"23\",\n"
+ " \"Afronding\": \"1\",\n"
+ " \"SchoolTypes\": {\n"
+ " \"VOVMBO\": \"2,5\",\n"
+ " \"MBO2\": \"2,5\",\n"
+ " \"MBO3\": \"1,5\"\n"
+ " }\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}