# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)(Afronding)([0-9\"\.\s:]*)(,\n)"
test_str = ("{\n"
" \"ImsManifestIdentifier\": \"MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58\",\n"
" \"PackageGuid\": \"ab8b5d84-b165-4806-a5fc-58d00ce2a195\",\n"
" \"PackageVersie\": 223296366,\n"
" \"ToetsGuid\": \"09f5836d-285a-4970-ad93-fb9610201e15\",\n"
" \"ToetsVersie\": 10001,\n"
" \"RuweScore\": \"0\",\n"
" \"Vaardigheid\": \"0\",\n"
" \"Afronding\": \"1\",\n"
" \"SchoolTypes\": {\n"
" \"VOVMBO\": \"1\",\n"
" \"MBO2\": \"1\",\n"
" \"MBO3\": \"1\"\n"
" }\n"
" }, {\n"
" \"ImsManifestIdentifier\": \"MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58\",\n"
" \"PackageGuid\": \"ab8b5d84-b165-4806-a5fc-58d00ce2a195\",\n"
" \"PackageVersie\": 223296366,\n"
" \"ToetsGuid\": \"09f5836d-285a-4970-ad93-fb9610201e15\",\n"
" \"ToetsVersie\": 10001,\n"
" \"RuweScore\": \"1\",\n"
" \"Vaardigheid\": \"14,0\",\n"
" \"Afronding\": \"1\",\n"
" \"SchoolTypes\": {\n"
" \"VOVMBO\": \"1,1\",\n"
" \"MBO2\": \"1,1\",\n"
" \"MBO3\": \"1\"\n"
" }\n"
" }, {\n"
" \"ImsManifestIdentifier\": \"MMANIFEST-2b0b0b9e-6a3c-4af6-ac18-903355ffab58\",\n"
" \"PackageGuid\": \"ab8b5d84-b165-4806-a5fc-58d00ce2a195\",\n"
" \"PackageVersie\": 223296366,\n"
" \"ToetsGuid\": \"09f5836d-285a-4970-ad93-fb9610201e15\",\n"
" \"ToetsVersie\": 10001,\n"
" \"RuweScore\": \"2\",\n"
" \"Vaardigheid\": \"23\",\n"
" \"Afronding\": \"1\",\n"
" \"SchoolTypes\": {\n"
" \"VOVMBO\": \"2,5\",\n"
" \"MBO2\": \"2,5\",\n"
" \"MBO3\": \"1,5\"\n"
" }\n"
" }")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.