$re = '/^[^0-3][0-9]{7}/m';
$str = '91234567
81234567
71234567
61234567
51234567
41234567
31234567
21234567
11234567
01234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);