package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^0-3][0-9]{7}`)
var str = `91234567
81234567
71234567
61234567
51234567
41234567
31234567
21234567
11234567
01234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}