import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^0-3][0-9]{7}";
final String string = "91234567\n"
+ "81234567\n"
+ "71234567\n"
+ "61234567\n"
+ "51234567\n"
+ "41234567\n"
+ "31234567\n"
+ "21234567\n"
+ "11234567\n"
+ "01234567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}