re = /(https?:\/\/)?gitlab\.com\/(?<author>[\w-]+)\/(?<repo>[\w-]+)(\/-\/)?(tree\/)?(?<branch>[\w-]+)?/m
str = 'https://gitlab.com/APN-Pucky/gentoo-apn/-/tree/pkglive'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end