$re = '/(https?:\/\/)?gitlab\.com\/(?<author>[\w-]+)\/(?<repo>[\w-]+)(\/-\/)?(tree\/)?(?<branch>[\w-]+)?/m';
$str = 'https://gitlab.com/APN-Pucky/gentoo-apn/-/tree/pkglive';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);