package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/)?gitlab\.com\/(?<author>[\w-]+)\/(?<repo>[\w-]+)(\/-\/)?(tree\/)?(?<branch>[\w-]+)?`)
var str = `https://gitlab.com/APN-Pucky/gentoo-apn/-/tree/pkglive`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}