use strict;
my $str = 'Кому-то понравилась твоя анкета:
Матвей, 18, 📍3 км';
my $regex = qr/^Кому-то понравилась твоя анкета(:|\(и еще \d+\))?\n\n(.+?), (\d+), (.+?)( – ([\s\S]+?))?(\n\nСообщение для тебя💌: ([\s\S]+))?$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}