const regex = /^Кому-то понравилась твоя анкета(:|\(и еще \d+\))?\n\n(.+?), (\d+), (.+?)( – ([\s\S]+?))?(\n\nСообщение для тебя💌: ([\s\S]+))?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Кому-то понравилась твоя анкета(:|\\(и еще \\d+\\))?\\n\\n(.+?), (\\d+), (.+?)( – ([\\s\\S]+?))?(\\n\\nСообщение для тебя💌: ([\\s\\S]+))?$', '')
const str = `Кому-то понравилась твоя анкета:
Матвей, 18, 📍3 км`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}