package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^Кому-то понравилась твоя анкета(:|\(и еще \d+\))?\n\n(.+?), (\d+), (.+?)( – ([\s\S]+?))?(\n\nСообщение для тебя💌: ([\s\S]+))?$`)
var str = `Кому-то понравилась твоя анкета:
Матвей, 18, 📍3 км`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}