$re = '/(?:\.)([a-z0-9]*)$/im';
$str = 'Aruba_Instant_8.3.0.x_User_Guide.pd2f2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);