const regex = /(?:\.)([a-z0-9]*)$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\.)([a-z0-9]*)$', 'igm')
const str = `Aruba_Instant_8.3.0.x_User_Guide.pd2f2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}