package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(?:\.)([a-z0-9]*)$`)
var str = `Aruba_Instant_8.3.0.x_User_Guide.pd2f2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}