$re = '/^(?\'asset\'02)_(?\'market1\'\w{3,})\/(?\'market2\'\w{3,})_(?\'type\'CY)(?\'offset\'L)_(?\'derivative\'PHY|FUT) (?\'period\')(?\'year\'\d{4})\b$/m';
$str = '02_AUT/TTF_H_CYL_PHY 2015
02_AUT/TTF_H_CYL_PHY 2016
02_GASPOOL_L/GASPOOL_H_CYL_PHY 2015
02_GASPOOL_L/GASPOOL_H_CYL_PHY 2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);