using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'CY)(?'offset'L)_(?'derivative'PHY|FUT) (?'period')(?'year'\d{4})\b$";
string input = @"02_AUT/TTF_H_CYL_PHY 2015
02_AUT/TTF_H_CYL_PHY 2016
02_GASPOOL_L/GASPOOL_H_CYL_PHY 2015
02_GASPOOL_L/GASPOOL_H_CYL_PHY 2016";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}