#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'CY)(?'offset'L)_(?'derivative'PHY|FUT) (?'period')(?'year'\d{4})\b$"
Local $sString = "02_AUT/TTF_H_CYL_PHY 2015" & @CRLF & _
"02_AUT/TTF_H_CYL_PHY 2016" & @CRLF & _
"02_GASPOOL_L/GASPOOL_H_CYL_PHY 2015" & @CRLF & _
"02_GASPOOL_L/GASPOOL_H_CYL_PHY 2016"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")