$re = '/^\+([^\d]{0,2}\d){11}$/m';
$str = '+7 (961) 772-86-22
+7 (961)772-86-22
+7 (961)772-8622
+3 (123) 123-12-32
+7 (961)7728622
+7961772-86-22
+7 (9 6 1) 7 7 2 8 6 2 2
+7 9 6 1 7 7 2 8 6 2 2
+7 9 6 1 7 7 2 8 6 2 2 3 4
+7 9 6 1 7 7 2 8 6 2
+7 961 77 286 22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);