#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+([^\d]{0,2}\d){11}$"
Local $sString = "+7 (961) 772-86-22" & @CRLF & _
"+7 (961)772-86-22" & @CRLF & _
"+7 (961)772-8622" & @CRLF & _
"+3 (123) 123-12-32" & @CRLF & _
"+7 (961)7728622" & @CRLF & _
"+7961772-86-22" & @CRLF & _
"+7 (9 6 1) 7 7 2 8 6 2 2" & @CRLF & _
"+7 9 6 1 7 7 2 8 6 2 2" & @CRLF & _
"+7 9 6 1 7 7 2 8 6 2 2 3 4" & @CRLF & _
"+7 9 6 1 7 7 2 8 6 2" & @CRLF & _
"+7 961 77 286 22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")