use strict;
my $str = '+7 (961) 772-86-22
+7 (961)772-86-22
+7 (961)772-8622
+3 (123) 123-12-32
+7 (961)7728622
+7961772-86-22
+7 (9 6 1) 7 7 2 8 6 2 2
+7 9 6 1 7 7 2 8 6 2 2
+7 9 6 1 7 7 2 8 6 2 2 3 4
+7 9 6 1 7 7 2 8 6 2
+7 961 77 286 22';
my $regex = qr/^\+([^\d]{0,2}\d){11}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}